Enabling TLS 1.1 and 1.2

Why do it need to update my browser?

Salesforce will begin disabling the TLS 1.0 encryption protocol that is used to access your account information with Cat Financial. The disablement of TLS 1.0 will prevent you from accessing your online account unless you make the update to your browser, following the steps listed below.

We take the protection of your data very seriously. The disablement of TLS 1.0 is being undertaken so we can maintain the highest security standards and promote the safety of your data, as well as align with industry-wide best practices. 

Please make this update by July 1, 2017.

 

Internet Explorer 8, 9, 10 & 11 Update (IE8, IE9, IE10, IE11)

If your current browser is Internet Explorer 8,9,10 or 11, you may not be prompted to make any changes to your encryption security. If you receive a message stating, "Stronger security is required," then your computer or mobile device is currently set to TLS 1.0 and you simply need to change your browser setting to TLS 1.1 and 1.2.

IE 7 will not support TLS 1.1, so a different browser will need to be used. Mobile IE versions 10 and below are not compatible with TLS 1.1 so a different browser will need to be used.  

To change your browser setting, please follow the instructions below. 

1) From your IE menu bar, click the gear setting to access Tools.

2) Scroll down and click Internet Options.

 

3) Click the Advanced tab under Internet Options and scroll down to Use TLS 1.0, 1.1 and 1.2. 

4) Uncheck the box next to Use TLS 1.0.

5) Check the boxes next to Use TLS 1.1 and Use TLS 1.2.

6) Click Apply

7) Once you have selected Use TLS 1.1 and 1.2 and clicked Apply, click OK to finish the update. 

Google Chrome Update

Google Chrome 38 and higher are compatible with TLS 1.1 and 1.2 by default so no update is required. 

Google Chrome 22 through 37 are compatible when running on Windows XP SP3, Vista or newer (desktop), OS X 10.6 (Snow Leopard) or newer (desktop), or Android 2.3 (Gingerbread) or newer (mobile).

Google Chrome 21 and lower are not compatible with TLS 1.1 and 1.2 so google 22 or higher will need to be used. 

Android Update

Android 4.3 (Jelly Bean) and below are not compatible with TLS 1.1 and 1.2 so 4.4 Android 4.4 and above will need to be used. 

Desktop Safari Update

Desktop Safari versions 7 and higher for OS X 10.9 (Mavericks) and higher are compatible with TLS 1.1 and 1.2 by default. No update is needed. 

Desktop Safari versions 6 and below are not compatible with TLS 1.1 and 1.2. Please use 7 and above. 

Mobile Safari version IOS 4 and below are not compatible with TLS 1.1 and 1.2.